Kitchen Aid Stand Mixer Grinder Attachment Problems


More from Cookware


Kitchen Aid Stand Mixer Grinder Attachment Problems

delys77 | | Nov 19, 2012 01:47 PM

Hello all

I was pleased to received my grinder attachment this past week, thinking that I would grind something up over the weekend. My first attempt was to grind some veal for a Mario Batali recipe I am trying tonight. Thinking it might be wise to grind it on Sunday in preparation for Monday's dinner in case I ran into some problems, I put the machine to the task Sunday afternoon.

I started with a little over 1 lb of veal stew meat that had already been cubed. I put in into the freezer for about 35 minutes so that it was nice and chilled (the machine attachments also went into the freezer for about an hour to make sure they were cold). I got all set up to go, and then spent the next 40 minutes or so wrestling with the attachment.

The grinder had to be taken apart 2 or 3 times on the first pass through as meat sinews were getting caught in the blade and blocking it. Once that was done it was still too course so I decided to push it through again (as the book recommends). The second pass was even worse because the blade was still getting blocked by chunks and sinew, and when I pushed with the plunger the meat was just mushing back up the feeder tube (ie. squeezing up the sides of the tube).

I finally had to pick though the meat and find as many sinews as I could and toss them. What was left over seemed fine, but I'm not sure as I am cooking with it tonight.

I am wondering if there are any of you out there who have read the above and found any major errors in my technique, or if there is something about veal that makes it extremely difficult to grind. To me the meat looked relatively low in fat and not very sinewy overall.

I have the pro series machine that generally powers through everything, but so far the grinder attachment seems far too wimpy for my taste.


Back to top