Site Feedback

Chowhound Broken in Firefox 4


More from Site Feedback

Site Feedback

Chowhound Broken in Firefox 4

embee | | Apr 13, 2011 11:35 AM

I have long been visiting Chowhound via Firefox. The advantages are too numerous to list, and include continuous page scrolling of long topics, the ability to easily change the page colours and type styles of the site (without affecting other sites), spell checking, and (though hardly desirable to the site owners), the ability to easily eliminate virtually all ads.

I upgraded to Firefox 4 last week and couldn't possibly go back. Unfortunately, Chowhound no longer works as expected. Pages display properly and can be read, and it is possible to successfully expand all posts within a topic. Much else is broken:

- The word "loading" appears at the beginning of the OP - top left - and never goes away - this seems to be diagnostic
- The awful sharing menu flies out as expected (and I wish it wouldn't - this implementation needs an overhaul), but displays "loading" in two places and never does actually load
- It is impossible to expand a single post
- It is impossibe to either reply to a post or create a new one

And these are just the showstoppers....

I am using Firefox 4 for Chowhound via an add-on called IE Tab Plus, which displays pages in Firefox using the MSIE engine. This works and preserves at least some of the Firefox benefits, but it is very annoying and doesn't work with most of my essential Firefox tools. I haven't noticed other comments about this, but suspect I'm not the only one. Most Sites simply work in Firefox; a percentage don't work at all. But these particular Firefox issues seem solvable.

Back to top